FR 0.4.0 dependencies on Linux

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

FR 0.4.0 dependencies on Linux

Nando Dessena
Hello,
so is it true that FR 0.4.0 requires wx and Mono? Can we do
something about the former (like allowing the option of statically
linking wx & the rest), and what the heck about the latter? :-)

Ciao
--
Nando Dessena
http://www.flamerobin.org



-------------------------------------------------------
SF.Net email is sponsored by:
Tame your development challenges with Apache's Geronimo App Server.
Download it for free - -and be entered to win a 42" plasma tv or your very
own Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php
_______________________________________________
Flamerobin-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/flamerobin-devel
Reply | Threaded
Open this post in threaded view
|

Re: FR 0.4.0 dependencies on Linux

Milan Babuskov-2
Nando Dessena wrote:
> Hello,
> so is it true that FR 0.4.0 requires wx and Mono? Can we do
> something about the former (like allowing the option of statically
> linking wx & the rest), and what the heck about the latter? :-)

I've just seen the post on firebird-tools, and replied. I'm waiting for
Scott's answer, to see which package he tried to install. Then we can
draw some conclusions.

--
Milan Babuskov
http://fbexport.sourceforge.net
http://www.flamerobin.org



-------------------------------------------------------
SF.Net email is sponsored by:
Tame your development challenges with Apache's Geronimo App Server.
Download it for free - -and be entered to win a 42" plasma tv or your very
own Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php
_______________________________________________
Flamerobin-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/flamerobin-devel
Reply | Threaded
Open this post in threaded view
|

Re: FR 0.4.0 dependencies on Linux

Milan Babuskov-2
In reply to this post by Nando Dessena
Nando Dessena wrote:
> Hello,
> so is it true that FR 0.4.0 requires wx and Mono? Can we do
> something about the former (like allowing the option of statically
> linking wx & the rest), and what the heck about the latter? :-)

I've just seen the post on firebird-tools, and replied. I'm waiting for
Scott's answer, to see which package he tried to install. Then we can
draw some conclusions.

BTW, we *are* statically linking wx, with exception of Debian package
built by Damyan.

--
Milan Babuskov
http://fbexport.sourceforge.net
http://www.flamerobin.org



-------------------------------------------------------
SF.Net email is sponsored by:
Tame your development challenges with Apache's Geronimo App Server.
Download it for free - -and be entered to win a 42" plasma tv or your very
own Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php
_______________________________________________
Flamerobin-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/flamerobin-devel
Reply | Threaded
Open this post in threaded view
|

Re: FR 0.4.0 dependencies on Linux

Milan Babuskov-2
In reply to this post by Nando Dessena
Nando Dessena wrote:
> so is it true that FR 0.4.0 requires wx and Mono? Can we do
> something about the former (like allowing the option of statically
> linking wx & the rest), and what the heck about the latter? :-)

It is half-true :)

Scott wanted to build FR from source, but I guess he didn't want to
bother with compiling wx too, so he took the precompiled wx library,
which was accidentally linked against Mono, thus the requirement. I
guess those who made the package had their reasons to include Mono, but
I won't waste my time to investigate.

The best option on Linux is to compile both wx and FR from sources. For
future releases, I will build a special version of wx, with --disabled
things that are not needed for FR; and link it statically to FR. That
would remove the wx, Xinerama and similar dependencies.

--
Milan Babuskov
http://www.flamerobin.org



-------------------------------------------------------
SF.Net email is sponsored by:
Tame your development challenges with Apache's Geronimo App Server.
Download it for free - -and be entered to win a 42" plasma tv or your very
own Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php
_______________________________________________
Flamerobin-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/flamerobin-devel